Login Unavailable
Incident Report for Coding Rooms
Postmortem

As earlier reported, today, at 11:52 AM PT our internal logs reported unavailability of Auth0 API, and continuous Web tests indicated that the Login function of Coding Rooms, which relies on Auth0 as a service provider, was not working. As a result, new logins into Coding Rooms were not available. This issue was not affecting users already in Coding Rooms. Per our investigation, Auth0 published a severe service interruption report at that time. This interruption affected Coding Rooms login for about 10 minutes, until just passed Noon PT.

As Auth0 has been an industry leader and a major provider of secure User and Login Management we consider the vendor being a key component of our infrastructure. However, recently, Auth0 service has been failing more frequently than it is acceptable for us and our users. As a mitigation measure, we are actively working on alternatives that would allow us continue uninterrupted and secure service to our users even in the event of a temporary failure of Auth0.

Thank you for your patience, support and understanding.

Posted Aug 31, 2021 - 23:31 UTC

Resolved
The login services have been stable. There is no final resolution of the interruption reported by the User Management vendor, but our services appear to be not affected any longer.
Posted Aug 31, 2021 - 19:14 UTC
Monitoring
The User and Login Management vendor is reporting that the services are coming back. At this point, login into Coding Rooms appears to be functional. We continue monitoring
Posted Aug 31, 2021 - 19:07 UTC
Identified
At this time, login into Coding Rooms is unavailable due to an ongoing issue with the User and Login Management vendor. We are checking on the status of their system
Posted Aug 31, 2021 - 19:02 UTC
This incident affected: Website, Web Application (app.codingrooms.com), and Authentication API.